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Preface

Thank you for purchasing Autonics products.
Be sure to read and follow the Safety Precautions thoroughly before use.
This manual contains information about the product and how to use it properly, so keep it in a place
where users can easily find it.

Preface 　 5
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Manual Guide

• Use the product after fully reading the contents of the manual.

• The manual explains the product functions in detail and does not guarantee the contents other than
the manual.

• Any or all of the manual may not be edited or copied without permission.

• The manual is not provided with the product.

• Download and use from our website (www.autonics.com).

• The contents of the manual are subject to change without prior notice according to the improvement
of the product’s performance, and upgrade notices are provided through our website.

• We put a lot of effort to make the contents of the manual a little easier and more accurate.
Nevertheless, if you have any corrections or questions, please feel free to comment through our
website.

Manual Guide 　 7
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Common Symbols in the Manual

Failure to follow instructions may result in serious injury or death.

Failure to follow instructions may result in injury or product damage.

Supplementary explanation of the function

Example of that function

Important information about the feature

Common Symbols in the Manual 　 9
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EtherCAT Trademark

English
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH,
Germany.

German
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff
Automation GmbH, Deutschland.

French
EtherCAT® est une marque d é pos é e et une technologie brevet é e sous licence de Beckhoff
Automation GmbH, Allemagne.

Italian
EtherCAT® è un marchio registrato, la tecnologia è brevettata ed è concessa in licenza da Beckhoff
Automation GmbH, Germania.

Spanish
EtherCAT® es una marca registrada y una tecnolog í a patentada, bajo licencia de Beckhoff Automation
GmbH, Alemania.

Japanese
EtherCAT® は、ドイツ Beckhoff Automation GmbH
によりライセンスされた特許取得済み技術であり登録商標です。

Korean
EtherCAT® 독일 Beckhoff Automation GmbH의 허가를 받은 등록 상표이자 특허 기술입니다.

Chinese
EtherCAT® 是注册商标和专利技术, 由德国倍福自动化有限公司授权。

EtherCAT Trademark 　 11
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Safety Considerations

Observe all 'Safety Considerations' for safe and proper operation to avoid hazards.

　Warning
1. Fail-safe device must be installed when using the unit with machinery that may cause serious injury

or substantial economic loss. (e.g., nuclear power control, medical equipment, ships, vehicles,
railways, aircraft, combustion apparatus, safety equipment, crime/disaster prevention devices, etc.)
Failure to follow this instruction may result in personal injury, fire or economic loss.

2. Do not use the unit in the place where flammable/explosive/corrosive gas, high humidity, direct
sunlight, radiant heat, vibration, impact, or salinity may be present.
Failure to follow this instruction may result in explosion or fire.

3. Do not disassemble or modify the unit.
Failure to follow this instruction may result in fire.

4. Do not connect, repair, or inspect the unit while connected to a power source.
Failure to follow this instruction may result in fire.

5. Check ‘Connections’ before wiring.
Failure to follow this instruction may result in fire.

　Caution
1. Use the unit within the rated specifications.

Failure to follow this instruction may result in fire or shortening the life cycle of the product.

2. Use dry cloth to clean the unit, and do not use water or organic solvent.
Failure to follow this instruction may result in fire or electric shock.

3. When connecting the power input and output, use AWG 22-16 cable and check the connecting
method of crimp terminal.
Failure to follow this instruction may result in fire or malfunction due to contact failure.

4. Keep metal chip, dust, and wire residue from flowing into the unit.
Failure to follow this instruction may result in fire or product damage.

5. Do not connect or disconnect connector (terminal) wire or power, when the product is operating.
Failure to follow this instruction may result in fire or malfunction of the product.

Safety Considerations 　 13



　Cautions during Use
1. Follow instructions in ‘Cautions during Use’. Otherwise, It may cause unexpected accidents.

2. BUS power and I/O power should be insulated by the individually insulated power device.

3. Power supply should be insulated and limited voltage/current or Class 2, SELV power supply device.

4. Use the rated standard cables and connectors. Do not apply excessive power when connecting or
disconnecting the connectors of the product.

5. Keep away from high voltage lines or power lines to prevent inductive noise.
In case installing power line and input signal line closely, use line filter or varistor at power line and
shielded wire at input signal line. For stable operation, use shield wire and ferrite core, when wiring
communication wire, power wire, or signal wire.

6. Do not use near the equipment which generates strong magnetic force or high frequency noise.

7. Do not touch the module communication connector part of the base.

8. Do not connect, or remove the base while connected to a power source.

9. For removing the terminal, body or base, do not operate units for a long time without it.

10. This unit may be used in the following environments.
① Indoors (in the environment condition rated in ‘Specifications’)
② Altitude max. 2,000 m
③ Pollution degree 2
④ Installation category II

The specifications and dimensions of this manual are subject to change without any notice for product
improvement. Be sure to read and follow the considerations written in the instruction manual, other
manuals, and technical information on our Autonics website.
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1. Reference Manuals

Be sure to read the reference manuals below to use the product correctly and follow
the precautions written in these manuals.
You can download the reference manuals on our Autonics website.

Installation manual It contains information for you to setup and install the ARIO Unit.

1. Key features of ARIO Series

2. Environmental conditions and handling method for
installation

3. Installation precautions

4. Instructions about maintenance, etc.

1. Reference Manuals 　 15



Coupler manual It contains information for you to configure and use the coupler
in the field network.

1. Communication protocol overview

2. Hardware information: specifications, indicators, connection
diagram, and dimensions, etc.

3. Software information: process images, and mapping
information, etc.

Module manual It contains information on the modules provided by Autonics.

1. Hardware information: specifications, indicators, connection
diagram, and dimensions, etc.

DAQMaster user manual It contains information and usage guides on ARIO-related
functions supported by DAQMaster, the comprehensive device
management program.

1. Change properties of the coupler and modules

2. Module configuration via virtual mode

3. Check the address map of the Unit

4. Check the diagnostic information of the coupler

5. Update the firmware version of the coupler, etc.

16 　 Autonics | ARIO-C-EC



2. Overview of the ARIO-C-EC

2.1. EtherCAT Protocol
The EtherCAT protocol, designed based on the Fieldbus system, supports low-latency control, high
flexibility in the topology, and user-friendly environment settings. The data is interpreted and copied
at all connected devices without receiving Ethernet packets under the EtherCAT network.
And the EtherCAT slave reads the received data while the frame has transmitted to the node.

The ARIO-C-EC supports the EtherCAT protocol. This coupler composes the physical structure of
connected modules and devices and creates input and output process images linked with the data of
EtherCAT. The process images make it possible to experience a flexible installation environment,
such as the mixed arrangement of analog and digital modules.

2.1. EtherCAT Protocol 　 17



2.2. Unit Descriptions

1. EtherCAT Communication Connectors It is a connector to connect with EtherCAT
Master such as PLC.
For detailed information on the communication
cable, refer to the  2.3, “EtherCAT
Communication Connector”.

2. CONFIG Port It is a port to connect to the PC where
DAQMaster is installed.

1. Port type: USB Type-B Micro

3. Indicators It displays the status of the coupler and
communication connection as shown below.
For detailed information on the indicators,
refer to the  3, Indicators.

1. Power and operating status of the coupler

2. EtherCAT communication status

18 　 Autonics | ARIO-C-EC



4. Power Supply Terminal It is a terminal block that supplies power to the
coupler and peripherals.
For detailed information on the device supply,
refer to the  2.4, “Connections of the Power
Terminal”.

5. Power Supply Contacts It is a contact that feeds the power input from
the power supply terminal.

1. Top input contacts: feed the power supply for
the coupler, module, and ABUS to be
operated.

2. Bottom input contacts: feed the power supply
for input and output signals of the connected
module.

2.2. Unit Descriptions 　 19



2.3. EtherCAT Communication Connector

• Be sure to use the connector and cable approved by the EtherCAT Technology
Group (ETG). Otherwise, use an Ethernet connector and cable that meets the
specifications of at least category 5e.

• Be sure not to exceed the cable length of 100 meters.

The RJ45 connector is used for EtherCAT communication connection.
For more information on the pin assignment, refer to the table below.

Pin no. Color of conductor based on T568A Signal Description

1 Green/White TD + Transmit Data +

2 Green TD - Transmit Data -

3 Orange/White RD + Receive Data +

6 Orange RD - Receive Data -

20 　 Autonics | ARIO-C-EC



2.4. Connections of the Power Terminal

Terminal no. Name Description

1, 7 System Power (24 VDC) Power supply for the coupler, module and
ABUS to be operated.
• The terminals feed the power supply to the
top input contacts.
• The POWER indicator lights up.

2, 8 System Power (0 VDC)

3, 9 Not Connected (NC) -

4, 10 Field Power (Positive: 24 VDC) Power supply for the input and output (I/O)
signals of the module.
• The terminals feed the power supply to the
bottom input contacts.
• The IO POWER indicator lights up.

5, 11 Field Power (Negative: 0 VDC)

6, 12 Frame Ground / Shield Frame ground

2.4. Connections of the Power Terminal 　 21
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3. Indicators

The indicators of the ARIO-C-EC coupler consist of elements indicating the operating status for the
coupler, connection status for the field network (EtherCAT), and Ethernet as shown in the figure below.
For detailed information on each indicator, refer to the following tables below.

3. Indicators 　 23



3.1. LEDs for the Coupler Status
1. The power supply status of the coupler

Indicator LED color Status Description

POWER Green ON Supply voltage: Normal

OFF Supply voltage: None

2. The status of the standby mode

Indicator LED color Status Description

SYSTEM Green ON Normal operation

Flashing Standby for connecting the master after
initialization of the coupler

OFF Stop

Red ON • Coupler initialization failure (non-recoverable)
• An unrecoverable error occurred.
• The type of field network and firmware version
mismatch (non-recoverable)

Flashing • Field network initialization failure
(non-recoverable)
• Changing the settings of rotary switches
(applicable models)

OFF Normal operation

3. The status of the module communication (ABUS)

Indicator LED color Status Description

DIAG Green ON Normal operation: Multi/Single-packet works

Flashing Hot-swap (normal state)

OFF • The operation of the coupler stopped
• An error occurred

Red ON ABUS communication error

Flashing The models of the replaced module and the
previous one mismatch (normal operation)

Flashing (2 times) No module connection (non-recoverable)

Flashing (3 times) Abnormal module operation (non-recoverable)

Flashing (4 times) The number of modules and data size exceeded

OFF Normal operation
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4. The status of power supply for the module

Indicator LED color Status Description

IO POWER Green ON Supply voltage for the I/O signals of modules
: Normal

OFF Supply voltage for the I/O signals of modules
: None

3.1. LEDs for the Coupler Status 　 25



3.2. LEDs for the Field Network Status
1. The status of the EtherCAT communication

Indicator LED color Status Description

RN Green ON EtherCAT state: OPERATIONAL
(Connection is established.)

Flashing (2.5 Hz) EtherCAT state: PRE-OPERATIONAL
(Initializing network settings,
Mailbox communication)

OFF EtherCAT state: INIT
(Initializing the EtherCAT communication,
communication unavailable)

Green,
Red

Flashing (once) EtherCAT state: SAFE-OPERATIONAL
(TxPDO communication)

2. The field network error

Indicator LED color Status Description

ER Red Flashing (2.5 Hz) Invalid configuration
• An PLC error occurred
• An error occurred in the settings of the register or
object

Flashing (once) Local error: The change of state is occurred in the
slave device.
• Host watchdog timeout
• Synchronization error
• The device enters SAFE-OPERATIONAL state.

Flashing (2 times) Application watchdog timeout
• Sync Manager watchdog timeout
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3.3. LEDs for the Ethernet Status
1. The status of the Ethernet connection

Indicator LED color Status Description

L/A IN,
L/A OUT

Green ON Link: The device is linked to the Ethernet, but does not
send/receive Ethernet frames.

Flashing Activity: The device is linked to the Ethernet and
sends/receives Ethernet frames.

OFF The device has no link to the Ethernet.

3.3. LEDs for the Ethernet Status 　 27



Refer to the timing chart below for the flashing operation of indicators.
The operation is repeated as flashing every 200 microseconds and standby
for 1 second.
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4. Process Images

4.1. Memory Map
The ARIO unit composes the memory map in its memory space to assign and manage the data
collected by the coupler and modules. The master in the field network controls the input and output
devices via this memory map generated by the ARIO unit.

The memory map is created based on the arrangement and data structure of the ARIO unit as shown in
the figure below. The memory map of modules consists of each module and contains its data.
The memory map of the coupler allocates the data considering the type (input or output) and
sequence of connected modules (e.g., the slot number of each module), and data size to the read and
write areas, making it easy to calculate the location of the master’s register. In this way, the memory
map comprised by the ARIO unit creates the input and output process images for data exchange.

• READ area
It is the area that transmits the data collected by the unit to the master in the field network.
It contains the input and diagnostic data.

• WRITE area
It is the area that transmits the output commands from the master of the field network.
It contains the output data.

4.1. Memory Map 　 29



4.2. Data Processing in the Modules
The data of the module is processed depending on the input and output signals.

• Digital modules
The bit-oriented digital module indicates the value of the corresponding bit position as 1.
The size of each channel is 1 bit and is grouped into bytes.

• Analog modules
The byte-oriented analog module indicates the value of the input or output signal to the
corresponding bytes. The size of each channel is grouped into words.

Module Example of input/output format Data processing size

Digital input/output
: Bit-oriented

2 channels/module (2-CH/module) 1-byte

4 channels/module (4-CH/module) 1-byte

8 channels/module (8-CH/module) 1-byte

16 channels/module (16-CH/module) 2-byte (= 1-word)

Analog input/output
: Byte-oriented

8-bit/channel (8-bit/CH) 1-byte

12-bit/channel (12-bit/CH) 2-byte (= 1-word)

16-bit/CH (16-bit/CH) 2-byte (= 1-word)

24-bit/channel (24-bit/CH) 4-byte (= 2-word)
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4.2.1. Check the Data of the Modules
You can check the data of modules connected with the coupler as shown in the figure below.
To check the data, go to Comm Mode » Run » I/O Monitor in the DAQMaster.
The binary, decimal, and hexadecimal are supported as the display format in the DAQMaster.

1. The value of input signals on the point (or channels) 1 and 2 of the digital input module
• Binary 0000 0011 (0x03)

2. The value of a voltage of 10.000 V applied to channel 1 of the analog input module
• Big endian: 0x270D (≈ 10,000DEC)

The data arrangements (the order or sequence) of the analog signal can be
expressed as big-endian or little-endian in the DAQMaster.
To select the endianness, go to Comm Mode » Property tab of the coupler »
Endian. (factory setting: Big-endian)

4.2. Data Processing in the Modules 　 31



4.3. Example of the Process Image
You can check the input and output process images of the unit (coupler + modules) on the AddressMap

menu in the DAQMaster. Firstly, the input modules are mapped, and then the output modules are
mapped. The first position of the input process image contains diagnostic information of the coupler
with a size of 16 bits (1 word).

DAQMaster: An arrangement example of the ARIO unit

DAQMaster: The address map of the ARIO unit
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4.3.1. Input Process Image

Byte Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0

0 0: Coupler Diagnostic Data High Byte 01)

1 Diagnostic data Low Byte 01)

2 2: DI04P - Ch.4 Ch.3 Ch.2 Ch.1

3 3: AI02V1 Ch.1 High Byte

4 Ch.1 Low Byte

5 Ch.2 High Byte

6 Ch.2 Low Byte

7 5: AI02V1 Ch.1 High Byte

8 Ch.1 Low Byte

9 Ch.2 High Byte

10 Ch.2 Low Byte

11 7: DI04P - Ch.4 Ch.3 Ch.2 Ch.1

12 9: DI04P - Ch.4 Ch.3 Ch.2 Ch.1

01) Refer to the  4.3.3, “Mapping of the Coupler Diagnostic Data”.

4.3.2. Output Process Image

Byte Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0

0 1: AO02V1 Ch.1 High Byte

1 Ch.1 Low Byte

2 Ch.2 High Byte

3 Ch.2 Low Byte

4 4: DO04P - Ch.4 Ch.3 Ch.2 Ch.1

5 6: DO04P - Ch.4 Ch.3 Ch.2 Ch.1

6 8: DO08P Ch.8 Ch.7 Ch.6 Ch.5 Ch.4 Ch.3 Ch.2 Ch.1
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4.3.3. Mapping of the Coupler Diagnostic Data
To check the value of the coupler diagnosis in the DAQMaster,
go to Comm Mode » Property tab of the coupler » Coupler State.

Byte Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0

0 High Reserved

1 Low CS MS WP AEM - ACS AT AC

AC (ABUS Configuration) The diagnostic information for the configuration of the
coupler and modules
0: Normal state
1: Module configuration error
• Cause 1: No connected modules
• Cause 2: The number of connected modules exceeded
• Cause 3: The data size of module exceeded
• Cause 4: Invalid arrangement of modules

AT (ABUS Timeout) The occurrence information of timeout
0: Multi-packet state (normal)
1: Single-packet state (timeout occurred)
• Cause 1: The module detached
• Cause 2: The module not recognized due to a noise
• Cause 3: Hot-swap state
• Cause 4: The module operation error

ACS (ABUS Communication State) ABUS communication status
0: Normal state
1: Communication error
• Cause 1: Replaced module mismatched
• Cause 2: Unknown communication error occurred

AEM (ABUS Empty Module) Checking the connected module
0: Normal state (one or more modules connected)
1: No module connected

WP (Warranty Period) Notice of product warranty period
(≤ 3 years, 157,680DEC)
0: Within the warranty period
1: End of warranty period
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MS (Module State) The status of connected modules
(running with DIAG indicator)
0: Normal state
1: Error

CS (Coupler State) The information on the coupler state
(running with SYSTEM indicator)
0: Normal state
1: Error
• Cause 1: Error occurred in the coupler initialization
and settings, etc.
• Cause 2: Error occurred in the field network
connection, etc.

4.3. Example of the Process Image 　 35
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5. TwinCAT3 Guide

• Be sure to see the version compatibility table of the ARIO Series on our Autonics
website to check the software/firmware(SW) and hardware(HW) versions of the
coupler and modules.

• Refer to the  6.2, “Update the Firmware Version” to update to the latest
software(firmware) version.

5.1. Before You Begin
Firstly, this chapter describes how to configure EtherCAT communication with the ARIO unit arranged
as shown in the figure below. After that, writing the ladder diagram, and monitoring the data in these
modules are given in this chapter.

Configuration of the ARIO Unit

5.1. Before You Begin 　 37



Configuration of the EtherCAT Master

• BECKHOFF PC-based PLC / Project planning software: TwinCAT3

This chapter describes based on BECKHOFF’s master (PLC) and software.
For detailed information on communication connection and usage method with the
master, refer to the user manuals provided by the specific manufacturer.
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5.2. Install the ESI File

The EtherCAT Slave Information (ESI) file contains specific data of the EtherCAT
slave and defines the parameters, process data, valid values and more.
The EtherCAT master recognizes the slave and also obtains the necessary information
for the control via the ESI file.

1. Download the ESI file of the ARIO-C-EC on our Autonics website.

2. Refer to the README.txt in the downloaded folder and select the ESI file suitable for the S/W version
of the coupler.

3. Copy the selected ESI file to the following subdirectory of the TwinCAT installation directory.
The path of the folder: ~\TwinCAT\3.1\Config\Io\EtherCAT

4. Launch the TwinCAT3.

To integrate the ESI file when the project file is running in the TwinCAT3,
go to the TwinCAT » EtherCAT Devices » Reload Device Descriptions on the top
menu.
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5.3. Install the Ethernet Adapter
1. Connect the cable connected to the EtherCAT communication connector of the coupler to the port

on the device where the TwinCAT3 is installed.

2. Launch the TwinCAT 3.

3. Select the TwinCAT » Show Realtime Ethernet Compatible Device on the top menu.
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4. Select the LAN card that is connected with the coupler in the sub-list of the Compatible devices,
and then select Install . Selecting a device in the sub-list of the Incompatible devices does not
guarantee a successful installation.

5. Check that the LAN card is located to the sub-list of the Installed and Ready to use devices
(realtime capable). The installation of LAN card is completed.
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5.4. Add the ARIO Unit

The number next to the Device/Box in the figure below may vary depending on the
installation environment.

1. Right-click on the Solution Explorer » I/O » Devices.

2. Select the Scan .

3. In the pop-up window, confirm the checkbox of the Device 2 (EtherCAT) and select the OK .
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4. Check the Solution Explorer » Box 1 (ARIO-C-EC).
The Device and Box shown in the Solution Explorer are defined as below.

◦ Device 2 (EtherCAT): EtherCAT master

◦ Box 1 (ARIO-C-EC): EtherCAT slave

If Box no.(ARIO-C-EC) does not appear in the Solution Explorer,
check the coupler status of the power supply and the EtherCAT communication
cable.
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5. Double-click the Solution Explorer » Box 1 (ARIO-C-EC).

6. Check the Online Data in the Editor Window » CoE-Online tab.

7. Check the connected modules in the Editor Window » Slots tab.

8. The ARIO unit has been successfully added.
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5.5. Mapping of Connected Unit

5.5.1. CoE-Online Tab
If the EtherCAT slave supports the CAN application protocol over EtherCAT (CoE) protocol,
the CoE-Online tab is displayed. In this tab, you can check the object list of the slave device and the
modules connected with the coupler.

TwinCAT3: CoE-Online tab (diagnostic function of the coupler: disabled)

5.5. Mapping of Connected Unit 　 45



Object descriptions

0x1000 It has the information on Device type including device name, hardware, and
software version of the slave, etc.

0x1018 It is Identity Object which has the information for the identification of the slave
device.

0x6000 It shows Input PDOs. (input from the perspective of the EtherCAT master)

0x7000 It shows Output PDOs. (output from the perspective of EtherCAT master)

0x1A00 It shows the objects that can be mapped to TxPDO. (input PDO mapping)

0x1600 It shows the objects that can be mapped to RxPDO. (output PDO mapping)

0x1C13 It assigns the mapping image of TxPDO to Sync Manager.

0x1C12 It assigns the mapping image of RxPDO to Sync Manager.
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5.5.2. Mapping Example of Process Data Objects (PDO)
• TxPDO

TxPDO Mapping Slot Application Object

Index Subindex Index Subindex Modules

0x1A00 0x01 0x6000 0x01 ARIO-S-DIO8N

0x1A01 0x01 0x6010 0x01 ARIO-S-DIO8P

0x1A02 0x01 0x6040 0x01 ARIO-S-AI04V1, Ch.1

0x02 0x02 ARIO-S-AI04V1, Ch.2

0x03 0x03 ARIO-S-AI04V1, Ch.3

0x04 0x04 ARIO-S-AI04V1, Ch.4

When the diagnostic function of the coupler is activated,
the data area is allocated as shown below.

Index Subindex Allocation Data

0x1A00 0x01 Coupler Diagnostic Data (MSB)

0x1A00 0x02 Coupler Diagnostic Data (LSB)

• RxPDO

RxPDO Mapping Slot Application Object

Index Subindex Index Subindex Modules

0x1602 0x01 0x7020 0x01 ARIO-S-DO08P

0x1603 0x01 0x7030 0x01 ARIO-S-DO08N

0x1605 0x01 0x7050 0x01 ARIO-S-AO04V1, Ch.1

0x02 0x02 ARIO-S-AO04V1, Ch.2

0x03 0x03 ARIO-S-AO04V1, Ch.3

0x04 0x04 ARIO-S-AO04V1, Ch.4
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5.5.3. Mapping Example of PDO Assign
• TxPDO Assign

Index Subindex Allocation Data

0x1C13 0x01 ARIO-S-DIO8N

0x02 ARIO-S-DIO8P

0x03 ARIO-S-AI04V1

• RxPDO Assign

Index Subindex Allocation Data

0x1C12 0x01 ARIO-S-DO08P

0x02 ARIO-S-DO08N

0x03 ARIO-S-AO04V1
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5.6. PLC Project

5.6.1. Create a Project File
1. Select the Solution Explorer » PLC » Add New item.

2. In the pop-up window, select the Standard PLC Project. Enter a project name and select the Add .
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3. MAIN (PRG) is created by default in the sub-list of the Solution Explorer » POUs.
MAIN (PRG) only supports ST language.

4. Right-click on the Solution Explorer » PLC » POUs and select the Add » POU….

5. In the pop-up window, designate the Name, Type, and Language and select the Open .
The Ladder Logic Diagram (LD) is selected in the figure below.
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6. The screen for writing a ladder logic appears. A function block (FB) is also added.
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5.6.2. Configure a Ladder Logic

This chapter describes how to configure the logic about giving the input signal on ch.1
of the digital input module and writing the output signal to ch.1 of the digital output
module. After that, monitoring the data of the logic on a real-time basis is given in this
chapter.

1. Declare a variable in the Textual view of the POU tab.
To configure a logic, drag the desired elements from the Toolbox to the area below.

2. Configure the main logic on the Solution Explorer » POUs » MAIN (PRG).
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3. Select the Build » Build Solution and continue.

4. Right-click on the Solution Explorer » Instance » PlcTask Inputs » MAIN.binput1,
and select the Change Link….

5. Select the OK  for a mapping of input variables.
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6. In the same way as above, right-click on the Solution Explorer » Instance » PlcTask Outputs »
MAIN.boutput1 and select the Change Link…. Select the OK  for mapping of output variables.

7. Select the TwinCAT » Active Configuration and continue.

8. When the process is completed, you will see the Run Mode icon at the bottom of the screen.
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5.6.2.1. Monitor the Ladder

1. Select the Login icon to enter monitoring mode.

2. Select the Start icon to start monitoring.
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3. You can check that the input signal on the ch.1 of the digital input module and the output signal
on the ch.1 of the digital output module.

◦ MAIN screen

◦ POU screen
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6. DAQMaster

6.1. Monitor the ARIO Unit
1. Connect the CONFIG port of the ARIO coupler to the PC where the DAQMaster is installed.

2. Select the Supported Device List » AUTONICS » ARIO Config to add the ARIO coupler and then
select the Connect » Scan to import the connected ARIO unit. (Comm Mode state)
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3. When Selecting the I/O List » ARIO Config, the tag list of the connected input/output module is
displayed. Double-click the tag to be monitored to add it on the DAQ List window.

4. The tags are added on the DAQ List window as shown below.
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5. Double-click the RunTime Screen » Data » (e.g.) Multi Panel to configure the visualized monitoring
screen. A multi-panel window will be created on the DAQ Space window.

6. Drag and drop the tags added on the DAQ List window to the Multi Panel window.
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7. When selecting the Project » Run, you can monitor the channel status of the module.
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6.2. Update the Firmware Version
You can check the firmware (software) version of the coupler on the Comm Mode » Property tab of
the coupler » FW Version in the DAQMaster. To update the coupler’s firmware, you need to select the
Comm Mode » Property tab of the coupler » System configuration.

With Internet connection

1. Select the Firmware update  to perform the update.

Without Internet connection

1. Download the latest firmware version of the coupler from the Autonics website.

2. Select the Load firmware file  to import the downloaded .zip file.

3. Select the latest version of ARIO-C-EC at the Firmware version list .

4. Select the Firmware update  to perform the update.
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7. Dimensions

• For the detailed drawings, follow the Autonics website.

• Unit: mm
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End module
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8. Specifications

8.1. Electrical/Mechanical Specifications
Max. number of
connectable modules ≤ 64 (The length of connected modules: ≤ 768 mm)

Memory size • Input: 512-byte
• Output: 512-byte

Power supply • Unit (coupler + module): ≤ 9.6 W, ≤ 400 mA (≤ 200 mA/CH, 2-CH/COM)
• I/O: ≤ 96 W, ≤ 4,000 mA (≤ 2,000 mA/CH, 2-CH/COM)

Supply voltage • Coupler input voltage: 24 VDC

• ABUS supply voltage: 5 VDC, ≤ 960 mA
• I/O supply voltage: 24 VDC

Current consumption • The standby and run mode: 200 mA
• The maximum load: 400 mA (at coupler max. load)

Field network
connection RJ45 X 2

DAQMaster connection USB 2.0 type Micro B

Installation method DIN rail mounting

Material Terminal: PA6, Body: MPPO, Base: PA6, POM

Unit weight
(packaged)

≈ 165 g
(≈ 265 g)
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8.2. Environmental Conditions
Insulation resistance ≥ 100 MΩ (500 VDC megger)

Dielectric strength 1000 VAC 50/60 Hz for 1 minute

Noise immunity 500 VDC the square wave noise (pulse width: 1 ㎲) by the noise simulator

Vibration 0.7 mm double amplitude at frequency of 10 to 55 Hz (for 1 minute)
in each X, Y, Z direction for 1 hour

Vibration
(malfunction)

0.5 mm double amplitude at frequency of 10 to 55 Hz (for 1 minute)
in each X, Y, Z direction for 10 minutes

Shock 300 m/s² (≈ 30 G) in each X, Y, Z direction for 3 times

Shock (malfunction) 100 m/s² (≈ 10 G) in each X, Y, Z direction for 3 times

Ambient temperature -10 to 55 ℃, storage: -25 to 70 ℃ (no freezing or condensation)

Ambient humidity 35 to 85 %RH, storage: 35 to 85 %RH (no freezing or condensation)

Protection rating IP20 (IEC standard)
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9. Communication Interface

9.1. Ethernet
Ethernet standard 100BASE-TX

Cable spec. The cable approved by the EtherCAT Technology Group (ETG)
or meets at least Cat 5e

Transmission rate 100 Mbps

Cable length ≤ 100 m

Protocol EtherCAT

Number of nodes ≤ 65,535

Address settings Auto

Topology Bus, Line, Star, Tree, Drop Line

ESI file Download the ESI file on our Autonics website

9.2. ABUS
Transmission rate 4 Mbps

Topology Bus, Drop Line

9.1. Ethernet 　 67



www.autonics.com

Dimensions or specifications on this manual are subject to change and some models may be discontinued without notice.


	ARIO-C-EC : EtherCAT
	Contents
	Preface
	Manual Guide
	Common Symbols in the Manual
	EtherCAT Trademark
	Safety Considerations
	1. Reference Manuals
	2. Overview of the ARIO-C-EC
	2.1. EtherCAT Protocol
	2.2. Unit Descriptions
	2.3. EtherCAT Communication Connector
	2.4. Connections of the Power Terminal

	3. Indicators
	3.1. LEDs for the Coupler Status
	3.2. LEDs for the Field Network Status
	3.3. LEDs for the Ethernet Status

	4. Process Images
	4.1. Memory Map
	4.2. Data Processing in the Modules
	4.2.1. Check the Data of the Modules

	4.3. Example of the Process Image
	4.3.1. Input Process Image
	4.3.2. Output Process Image
	4.3.3. Mapping of the Coupler Diagnostic Data


	5. TwinCAT3 Guide
	5.1. Before You Begin
	5.2. Install the ESI File
	5.3. Install the Ethernet Adapter
	5.4. Add the ARIO Unit
	5.5. Mapping of Connected Unit
	5.5.1. CoE-Online Tab
	5.5.2. Mapping Example of Process Data Objects (PDO)
	5.5.3. Mapping Example of PDO Assign

	5.6. PLC Project
	5.6.1. Create a Project File
	5.6.2. Configure a Ladder Logic


	6. DAQMaster
	6.1. Monitor the ARIO Unit
	6.2. Update the Firmware Version

	7. Dimensions
	8. Specifications
	8.1. Electrical/Mechanical Specifications
	8.2. Environmental Conditions

	9. Communication Interface
	9.1. Ethernet
	9.2. ABUS


